sviluppo-web-qa.it

Errore 1274 dell'installazione di Criteri di gruppo

Sto cercando di distribuire un MSI tramite i Criteri di gruppo in Active Directory. Ma questi sono gli errori che ottengo nel registro eventi di sistema dopo aver effettuato l'accesso:

  • L'assegnazione dell'applicazione XStandard dall'installazione della politica non è riuscita. L'errore era: %% 1274
  • La rimozione dell'assegnazione dell'applicazione XStandard dall'installazione della politica non è riuscita. L'errore era: %% 2
  • Impossibile applicare le modifiche alle impostazioni di installazione del software. L'installazione del software distribuito tramite Criteri di gruppo per questo utente è stata posticipata al successivo accesso perché le modifiche devono essere applicate prima dell'accesso dell'utente. L'errore era: %% 1274
  • L'installazione del software di estensione lato client Criteri di gruppo non è stata in grado di applicare una o più impostazioni poiché le modifiche devono essere elaborate prima dell'avvio del sistema o dell'accesso dell'utente. Il sistema attenderà il completamento completo dell'elaborazione di Criteri di gruppo prima dell'avvio o dell'accesso successivo per questo utente e ciò potrebbe causare rallentamento delle prestazioni di avvio e avvio.

Quando riavvio ed eseguo nuovamente l'accesso ottengo semplicemente gli stessi messaggi sulla necessità di eseguire l'aggiornamento prima del successivo accesso. Sono su un laptop a 32 bit con Windows Vista. Sono piuttosto nuovo nell'implementazione tramite criteri di gruppo, quindi quali altre informazioni sarebbero utili per determinare il problema? Ho provato un MSI diverso con gli stessi risultati. Sono in grado di installare MSI usando la riga di comando e msiexec quando ho effettuato l'accesso al computer, quindi so che l'MSI funziona bene almeno.

40

Stai vedendo il temuto flagello dell'elaborazione asincrona delle politiche. Non è una "funzionalità" (ed è stata disattivata per impostazione predefinita in Windows 2000, ma è attivata per impostazione predefinita in Windows XP e oltre) e causa esattamente ciò che stai vedendo - comportamento non deterministico con l'elaborazione alcuni tipi di GPO.

In a GPO applicabile a quel computer, aggiungi la seguente impostazione:

  • Impostazioni del computer
    • Modelli amministrativi
      • Sistema
        • Accedere
          • Attendere sempre la rete all'avvio e all'accesso del computer - Abilitato

Dopo aver impostato questo (e consenti a GPO di replicarsi se ti trovi in ​​un ambiente multi-DC), esegui un "gpupdate/force/boot" sul PC soggetto. Si riavvierà e dovresti vedere l'installazione del software.

"Attendi sempre la rete all'avvio e all'accesso del computer" rallenta leggermente l'avvio e l'accesso perché tutte le estensioni GPO possono essere elaborate, ma il lato positivo è che tutte GPO possono essere elaborate.

56
Evan Anderson

Ho provato Attendi sempre la rete all'avvio e all'accesso del computer - Abilitato impostazione dalla risposta di @Evan Anderson, ma non è stato fino a quando non ho aggiunto questa impostazione anche di seguito che ha permesso l'installazione del software. Non sono sicuro se fosse una combinazione di entrambe le impostazioni o meno. Ora funziona, quindi sto lasciando entrambe le impostazioni.

In un criterio di gruppo applicato a queste workstation, accedere a:

Configurazione computer> Politiche> Modelli amministrativi> Sistema> Criteri di gruppo

Abilita il Specifica il tempo di attesa per l'elaborazione della politica di avvio . Imposta Tempo di attesa (in secondi) : = 120

120 potrebbe essere eccessivo, ma ha funzionato per me. Altri forum hanno suggerito di impostarlo su 30 secondi. Anche se 30 secondi sono predefiniti (quando non è impostato il criterio), forzandolo a 30 secondi ha funzionato per loro.

screen shot

14
Andrew Bucklin

Questo può accadere se l'applicazione è già installata ma msiexec non è in grado di disinstallarla. Lo scenario più comune è un'installazione manuale precedente con "Solo per me" selezionato anziché "Tutti coloro che accedono a questo computer".

È possibile utilizzare l'utilità di pulizia di Windows Installer ( http://support.Microsoft.com/kb/290301 ) per indurre il PC a pensare che l'app non sia più presente e quindi dovrebbe andare bene .

6
Maximus Minimus

E ho appena trovato un'altra causa diversa di questo errore. Se "Spanning Tree" è configurato sullo switch Ethernet collegato alla workstation problematica, ritarderà l'attivazione della porta dello switch all'avvio del PC. Disabilitare Spanning Tree per la porta dello switch o abilitare "Spanning Tree Portfast" per lo switchport ha risolto questo problema su alcune delle mie stazioni di lavoro.

4
Richard

Ho avuto lo stesso problema ma nessuna delle correzioni sopra ha funzionato. Alla fine ho capito che c'era un altro GPO che cercava di installare il software prima del mio e che non riusciva con l'errore %% 1274 perché GPO stesso aveva le autorizzazioni sbagliate. Per qualche ragione quell'errore stava impedendo l'installazione del mio GPO, anche se il mio aveva i permessi corretti. Dopo aver disabilitato l'altro oggetto Criteri di gruppo, il mio GPO è stato installato correttamente.

2
user56113

La modifica di "Tempo di attesa elaborazione criteri di avvio" ha funzionato per me. Era impostato su 30 secondi, ma alcune workstation non funzionavano ancora con %% 1274.

L'ho aumentato a 90 secondi ed erano felici.

2
pbc5501

Ho affrontato lo stesso comportamento con un paio di laptop. Hanno funzionato bene per un paio d'anni, e all'improvviso non hanno installato alcun nuovo software tramite gpo. Forzare l'impostazione "Tempo di attesa elaborazione criteri di avvio" sembra aver corretto il problema. Come detto prima dovrebbe essere 30sec per impostazione predefinita, ma per me sembrava che i laptop non aspettassero affatto all'avvio per le politiche ma saltarono subito. Tutti i laptop erano win7x64, DC Server2008R2 e Server2012.

1
hyvokar

A volte la tua politica di gruppo può essere rovinata. Prova a rimuovere l'intera chiave di registro HKLM/SOFTWARE/Microsoft/Windows/CurrentVersion/Criteri di gruppo. Probabilmente troverai di nuovo tutto da GP al riavvio. Potresti voler prima fare il backup del registro ...

1
Paul

Abbiamo avuto lo stesso problema. Abbiamo finalmente capito che i nostri laptop erano RADIUS autenticato su WiFi, e l'installazione di rete non poteva iniziare fino a quando l'utente non accedeva con credenziali AD (perché nessuna connessione di rete fino ad allora per eseguire in remoto l'installazione) file) E dopo che l'utente ha effettuato l'accesso, era troppo tardi perché l'installazione dovrebbe iniziare prima.

Quando il client si connetteva tramite Ethernet funzionava come un fascino!

1
Dan Munasinghe

La risposta di Evan Anderson va bene, ma manca un disclaimer piuttosto importante:

Ciò può rallentare in modo significativo accessi fuori dominio per laptop e client wireless.

Considerando la soluzione alternativa senza questo GPO è semplicemente riavviare due volte, non vedo davvero perché qualcuno dovrebbe togliersi quel compromesso.

0
Atta

Problema risolto!

Stavo accedendo ai computer client come utente di dominio con privilegi di amministratore Enterprise/Domain e potevo accedere senza problemi a una cartella condivisa contenente i pacchetti di installazione MSI. Tuttavia, a un certo punto ha provato ad accedervi tramite\IP\share_path_to_msi_packages_folder da un altro PC non di dominio e ha continuato a ricevere un pop-up di accesso. Fondamentalmente, anche se uno consente a tutti gli utenti/gruppi di dominio e non di dominio o le autorizzazioni di lettura/scrittura di "Tutti" sulla cartella condivisa, non funzionerebbe ancora e richiedimi nome utente/password, in modo da non consentire al client locale di estrarre i pacchetti indicati dall'oggetto Criteri di gruppo . Ciò è causato da accesso anonimo disabilitato per impostazione predefinita. Dopo averlo abilitato e dato le autorizzazioni di lettura/scrittura alla cartella MSI è stato quindi in grado di distribuire con successo la maggior parte dei pacchetti e solo synology-cloud-station-3.1.-3320.msi non è riuscito (è necessario esaminarlo). Sono stato anche in grado di accedere alla cartella condivisa da qualsiasi macchina non di dominio.

Stavo ricevendo questi messaggi di errore praticamente ogni 5 minuti in Eventi> Sistema:

101 L'assegnazione dell'applicazione 7-Zip 9.20 (edizione x64) dall'installazione dei pacchetti di base DOMAIN della politica non è riuscita. L'errore era: %% 1274

103 L'assegnazione dell'applicazione 7-Zip 9.20 (edizione x64) dall'installazione dei pacchetti di base DOMAIN della politica non è riuscita. L'errore era: %% 1274

108 Impossibile applicare le modifiche alle impostazioni di installazione del software. L'installazione del software distribuito tramite Criteri di gruppo per questo utente è stata posticipata al successivo accesso perché le modifiche devono essere applicate prima dell'accesso dell'utente. L'errore era: %% 1274

1112 Impossibile applicare le modifiche alle impostazioni di installazione del software. L'installazione del software distribuito tramite Criteri di gruppo per questo utente è stata posticipata al successivo accesso perché le modifiche devono essere applicate prima dell'accesso dell'utente. L'errore era: %% 1274

Impostare:

SERVERS DC1 (PDC) + DC2 (BDC) + DC3 (DBC) Windows 2012 R2 Standard completamente aggiornato

CLIENTI Windows 7 Pro SP1 (ripristino Dell pulito, pacchetti completamente aggiornati e in conflitto come il vecchio Adobe Flash disinstallato)

Ho già provato i client:

  • gpupdate/force
  • gpupdate/force/boot (entrambi chiedono di riavviare e generare un errore che non è stato applicato ai criteri)
  • gpresult/r (sembra buono)
  • sia i server che i client possono accedere all'unità condivisa in cui sono memorizzati i pacchetti MSI
  • riavviato più volte DC1 e client dopo le modifiche all'oggetto Criteri di gruppo

UAC di disabilitazione oggetto Criteri di gruppo:

* Computer Configuration * Policies * Windows Settings * Security Settings * Local Policies * Security Options ELEVATE WITHOUT PROMPTING: User Account Control: Behaviour of the elevation Prompt for administrators in Admin Approval Mode DISABLE: User Account Control: Detect application installation and Prompt for elevation DISABLE: User Account Control: Run all administrators in Admin Approval Mode

GPO deploy base software: * Computer Configuration * Policies * Administrative Templates * System * Logon ENABLE: Always wait for the network at computer startup logon * Group Policy ENABLE: Specify startup policy processing wait time (temporarily set to 120 will change to 30 later)

* Computer Configuration * Policies * Software Installation * 7-Zip 9.20 (x64 edition) v9.20 Assigned \LANIP\Utils\Software\GPO\7Zip-7z920-x64.msi * Google Chrome v66.41 Assigned \LANIP\Utils\Software\GPO\googlechromestandaloneenterprise.msi * Mozilla Firefox (en-GB) v35.0 Assigned \LANIP\Utils\Software\GPO\firefox-35.0.1-en-gb-msi * Synology Cloud Station v3.1 Assigned \LANIP\Utils\Software\GPO\synology-cloud-station-3.1.-3320.msi

Tutti gli oggetti Criteri di gruppo vengono inseriti negli oggetti Criteri di gruppo, quindi collegati dagli oggetti Criteri di gruppo direttamente nel nostro dominio. Altre impostazioni come IE restrizioni da un altro GPO imposta allo stesso modo si applicano al client correttamente.

Non ci sono altri errori in AD, DHCP, DNS funzionano perfettamente, le macchine ottengono IP e possono risolvere i nomi tramite nslookup e fare un ping su IPv4/IPv6.

0
webcoder